• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 KIA Stinger Forum and KIA Stinger community dedicated to KIA Stinger owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the KIA Stinger Forum today!

All warning lights on.

Tank55444

New Member
Messages
6
Likes
1
State
MD
Country
United States
#1
Woke up to every warning light on. Stock 2019 gt awd. Closest dealer appt is in 2 weeks . If i try to schedule online. E brake will also not engage .



Any ideas..
 

Attachments

Messages
219
Likes
94
City
Charlotte
State
NC
Country
United States
#2
Call the guy that sold u the car, tell him to figure out how to get you in asap. Be nice and tell him you can't wait two weeks:) he should be able to talk with someone to get you worked in.


Sent from my iPhone using Tapatalk
 
OP
T

Tank55444

New Member
Messages
6
Likes
1
State
MD
Country
United States
Thread Starter #3
Ya think I'm gonna have to call him up tomaorrow. And hope for the best. Only thing i could think of was to check battery wires and voltage. All looks good. I turned it on after checking . All lights except the check engine went off. I moved it 5 feet to another parking spot. In case it has to sit for longer then expected. All other lights came right back on as soon as i pulled it forward into the spot. So waiting game with a bad taste in my mouth im hoping is something dumb like a loose wire.....

Here's to hoping ^_^
 
OP
T

Tank55444

New Member
Messages
6
Likes
1
State
MD
Country
United States
Thread Starter #4
So a guy from another thread said he had same issues . It turns out ice froze over his front sensors.. i had a pollen cloud roll through. So i used a hose to spry off my car really quick. Turned it on.. all lights went off except check engine. And my speedometer is working fine now..

Scarey way to tell a guy to wash his car lol.
 

robz32

Moderator
Staff Member
Messages
1,708
Likes
484
State
TX
Country
United States
#6
So a guy from another thread said he had same issues . It turns out ice froze over his front sensors.. i had a pollen cloud roll through. So i used a hose to spry off my car really quick. Turned it on.. all lights went off except check engine. And my speedometer is working fine now..

Scarey way to tell a guy to wash his car lol.
Stingers like stay looking good always [coolsmile]

Glad to hear the issue was a simple one. The CEL can be erased by plugin in an OBD scanner and heving the code deleted. Autozone can do it for free. Take note of the code though, just in case.
 


Top