• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 KIA Stinger Forum and KIA Stinger community dedicated to KIA Stinger owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the KIA Stinger Forum today!

Who's experienced issues with the Lap 3 Uncle Chip?

Messages
129
Reactions
13
State
Non-US
Country
Canada
What I Drive
2011 Acura MDX
#1
Wanted to start a thread where we can get some feedback for those who have intalled their Lap3 Unlce Chip on their Stinger to see if they have experienced any issues. From what I've read on this forum there are concerns about spark plugs issues, engine knocks, misfires, requiring a catch can install, coil, etc.

I think this would be very useful for those including myself who are looking to getting a Chip soon.
 
Messages
420
Reactions
177
State
Non-US
Country
Bahrain
What I Drive
2011 - 997.2TT
#2
Wanted to start a thread where we can get some feedback for those who have intalled their Lap3 Unlce Chip on their Stinger to see if they have experienced any issues. From what I've read on this forum there are concerns about spark plugs issues, engine knocks, misfires, requiring a catch can install, coil, etc.

I think this would be very useful for those including myself who are looking to getting a Chip soon.
I posted my experience in another thread. But briefly, I installed the LAP3 ran the car on 93octane and the setting on 93octane also. Started getting misfiring, had to go through 2 plugs and a coil to get the car back to normal again. LAP3 no longer installed.
 
Messages
449
Reactions
71
State
MO
Country
United States
What I Drive
'05 Pontiac GTO
#3
I posted my experience in another thread. But briefly, I installed the LAP3 ran the car on 93octane and the setting on 93octane also. Started getting misfiring, had to go through 2 plugs and a coil to get the car back to normal again. LAP3 no longer installed.
I think the consensus was that the 91 octane setting on the Lap3 was where you wanted it with 93 octane fuel. Doesn't make sense but I think that's what people are doing. Time will tell about durability.
 
Messages
30
Reactions
36
State
PA
Country
United States
#4
I can?t speak for the V6, but the little 4cyl is still running strong. I?ve had it installed for about 700 miles thus far. No knocking, misfires, etc. and I bring it to redline pretty often. I?m running it on the 93(94?) setting with 93 gas. I have not changed my plugs out and I have not installed a catch can. I may in the future, but I?m thinking a few thousand miles without one shouldn?t grenade the engine. The only problem I have been having is the small gas tank. I have to fill up twice as often now. I guess I might just have a lead foot...
 
Messages
347
Reactions
165
State
NC
Country
United States
#5
There's a post on the main Stinger forum where someone is detailing their issues with the LAP3. Their car is having issues. I believe he's replacing the spark plugs. LAP3 has only been installed for a week.

I'm steering clear.
 

Kazz

500 Posts Achieved
Messages
507
Reactions
132
State
IL
Country
United States
What I Drive
2018 Micro Blue Stinger GT2 AWD
#6
Having this chip work for different model cars seems problematic in my mind. Running a 91 octane setting when using 93 octane fuel means the chip's not optimized for the 3.3T Stinger. I hope those having issues get things taken care of to their satisfaction and soon!
 
Messages
36
Reactions
12
State
CA
Country
United States
What I Drive
2018 stinger GT2 AWD
#7
I installed chip and had to lower setting because it was causing really bad misfires Andes up killing a few plugs and even a coil pack which I had never seen before. Use 89 setting with 91 fuel and 91 setting with 93 fuel.
 
Messages
78
Reactions
22
State
Non-US
Country
Singapore
#8
I can?t speak for the V6, but the little 4cyl is still running strong. I?ve had it installed for about 700 miles thus far. No knocking, misfires, etc. and I bring it to redline pretty often. I?m running it on the 93(94?) setting with 93 gas. I have not changed my plugs out and I have not installed a catch can. I may in the future, but I?m thinking a few thousand miles without one shouldn?t grenade the engine. The only problem I have been having is the small gas tank. I have to fill up twice as often now. I guess I might just have a lead foot...
Would you happen to know what plugs your Stinger is running? Read somewhere that an owner found Denso plugs installed and another had a different brand installed.
 

robz32

2000 Posts Achieved
Staff Member
Messages
2,001
Reactions
643
City
Houston
State
TX
Country
United States
What I Drive
Stinger GT2
#9
So far we know from owner [MENTION=46]STINGER[/MENTION] that the 3.3TT is equipped with NGK plugs. No info yet on the 2.0T
 
Messages
17
Reactions
4
State
NM
Country
United States
What I Drive
2018 Stinger GT1
#10
Ran the Lap3 for about a week. 91 setting on 91 octane. Stock plugs and no other mods. Got the flashing CEL under boost. Removed the tune and the jerking under boost remained. Hoping it's just a plug (maybe a coil based upon other reports noted here) but won't know until its looked at later this week. It drives fine if I don't push it. I'll post findings once I know definitively. I will also not be putting the tune back on the car. Lesson learned.
 

VegasStinger

500 Posts Achieved
Messages
668
Reactions
49
State
NV
Country
United States
#11
Ran the Lap3 for about a week. 91 setting on 91 octane. Stock plugs and no other mods. Got the flashing CEL under boost. Removed the tune and the jerking under boost remained. Hoping it's just a plug (maybe a coil based upon other reports noted here) but won't know until its looked at later this week. It drives fine if I don't push it. I'll post findings once I know definitively. I will also not be putting the tune back on the car. Lesson learned.
Keep us posted. Do you have the 3.3 or 2.0?
 

Kazz

500 Posts Achieved
Messages
507
Reactions
132
State
IL
Country
United States
What I Drive
2018 Micro Blue Stinger GT2 AWD
#12
Sounds at first like spark blowout but if it's there after removal, that would imply the plug(s) incurred a problem. Good luck and keep us posted!
 
Messages
17
Reactions
4
State
NM
Country
United States
What I Drive
2018 Stinger GT1
#14
Sounds at first like spark blowout but if it's there after removal, that would imply the plug(s) incurred a problem. Good luck and keep us posted!
The symptoms I experienced are similar to those outlined in [MENTION=46]STINGER[/MENTION]'s posts about the chip. I'm hoping it's just a plug but could also be a coil pack. The tech thinks it's the 5th cylinder. I'll hopefully know more Saturday. One thing I know for sure, driving this car conservatively sucks.
 
Messages
420
Reactions
42
State
LA
Country
United States
What I Drive
2010 Kia Forte
#15
The symptoms I experienced are similar to those outlined in [MENTION=46]STINGER[/MENTION]'s posts about the chip. I'm hoping it's just a plug but could also be a coil pack. The tech thinks it's the 5th cylinder. I'll hopefully know more Saturday. One thing I know for sure, driving this car conservatively sucks.
Would love to get updates on your situation too.
 
Messages
97
Reactions
78
State
Non-US
Country
Australia
#16
Hey guys. Been running the uncle chip for a bit now. Stinger GT 3.3tt. Cars done nearly 10,000km. No probs at all. Although at limit of pcm torque tables havent had a single prob. Gave us exactly 3psi more boost. Waiting on the full ecu edit before we launch our products. Shold be very soon

Kindest regards Jon
 

SeoulStinger

500 Posts Achieved
Messages
538
Reactions
37
State
CA
Country
United States
What I Drive
2015 Audi A6
#17
Hey guys. Been running the uncle chip for a bit now. Stinger GT 3.3tt. Cars done nearly 10,000km. No probs at all. Although at limit of pcm torque tables havent had a single prob. Gave us exactly 3psi more boost. Waiting on the full ecu edit before we launch our products. Shold be very soon

Kindest regards Jon
Thanks for the reply Jon. Are you running the stock plugs and do you know which brand plugs are in your Stinger? Someone mentioned on here before that it's possible the Stinger has two brands (Denso and NGK) they are using in different markets.
 
Messages
420
Reactions
177
State
Non-US
Country
Bahrain
What I Drive
2011 - 997.2TT
#18
Hey guys. Been running the uncle chip for a bit now. Stinger GT 3.3tt. Cars done nearly 10,000km. No probs at all. Although at limit of pcm torque tables havent had a single prob. Gave us exactly 3psi more boost. Waiting on the full ecu edit before we launch our products. Shold be very soon

Kindest regards Jon
You're killing us here with no updates :)
 
Last edited:
Messages
420
Reactions
42
State
LA
Country
United States
What I Drive
2010 Kia Forte
#19
[MENTION=217]Jonnytig[/MENTION] we miss your updates haha
 
Messages
270
Reactions
16
State
NC
Country
United States
#20
Hey guys, we've noted some customers foul plugs with the chip installed. We have also seen bare stock (no bolt-ons or chip) members foul plugs as well.

That being said we are looking into alternative plug options for those running the chip since both chipped and non-chipped customers have reported running into plug premature plug fouling. Not sure if the root is with the engine or the plugs or what but we are on top of it and will let the community know!
 


Top